Executive Summary

Summary
TitleZsh: User-assisted execution of arbitrary code
Informations
NameGLSA-201903-02First vendor Publication2019-03-10
VendorGentooLast vendor Modification2019-03-10
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Input validation errors in Zsh could result in arbitrary code execution.

Background

A shell designed for interactive use, although it is also a powerful scripting language.

Description

Two input validation errors have been discovered in how Zsh parses scripts:

* Parsing a malformed shebang line could cause Zsh to call a program listed in the second line (CVE-2018-0502)
* Shebang lines longer than 64 characters are truncated (CVE-2018-13259)

Impact

An attacker could entice a user to execute a specially crafted script using Zsh, possibly resulting in execution of arbitrary code with the privileges of the process.

Workaround

There is no known workaround at this time.

Resolution

All Zsh users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-shells/zsh-5.6"

References

[ 1 ] CVE-2018-0502 : https://nvd.nist.gov/vuln/detail/CVE-2018-0502
[ 2 ] CVE-2018-13259 : https://nvd.nist.gov/vuln/detail/CVE-2018-13259

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201903-02

Original Source

Url : http://security.gentoo.org/glsa/glsa-201903-02.xml

CWE : Common Weakness Enumeration

%idName
100 %CWE-20Improper Input Validation

CPE : Common Platform Enumeration

TypeDescriptionCount
Os3

Nessus® Vulnerability Scanner

DateDescription
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-5ad8e216d2.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-16bb8b00c5.nasl - Type : ACT_GATHER_INFO
2018-10-11Name : The remote Amazon Linux 2 host is missing a security update.
File : al2_ALAS-2018-1089.nasl - Type : ACT_GATHER_INFO
2018-09-17Name : The remote Fedora host is missing a security update.
File : fedora_2018-8b1b2373b4.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-03-10 05:18:44
  • First insertion