Executive Summary

Summary
Titlenetwork-manager-ssh security update
Informations
NameDSA-4637First vendor Publication2020-03-09
VendorDebianLast vendor Modification2020-03-09
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector :
Cvss Base ScoreN/AAttack RangeN/A
Cvss Impact ScoreN/AAttack ComplexityN/A
Cvss Expoit ScoreN/AAuthenticationN/A
Calculate full CVSS 2.0 Vectors scores

Detail

Kobus van Schoor discovered that network-manager-ssh, a plugin to provide VPN integration for SSH in NetworkManager, is prone to a privilege escalation vulnerability. A local user with privileges to modify a connection can take advantage of this flaw to execute arbitrary commands as root.

This update drops support to pass extra SSH options to the ssh invocation.

For the oldstable distribution (stretch), this problem has been fixed in version 1.2.1-1+deb9u1.

For the stable distribution (buster), this problem has been fixed in version 1.2.10-1+deb10u1.

We recommend that you upgrade your network-manager-ssh packages.

For the detailed security status of network-manager-ssh please refer to its security tracker page at: https://security-tracker.debian.org/tracker/network-manager-ssh

Original Source

Url : http://www.debian.org/security/2020/dsa-4637

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2020-03-09 21:17:57
  • First insertion