Executive Summary

Summary
Titlenetty security update
Informations
NameDSA-4597First vendor Publication2020-01-03
VendorDebianLast vendor Modification2020-01-03
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:P/A:N)
Cvss Base Score5Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

It was reported that Netty, a Java NIO client/server framework, is prone to a HTTP request smuggling vulnerability due to mishandling whitespace before the colon in HTTP headers.

For the oldstable distribution (stretch), this problem has been fixed in version 1:4.1.7-2+deb9u1.

For the stable distribution (buster), this problem has been fixed in version 1:4.1.33-1+deb10u1.

We recommend that you upgrade your netty packages.

For the detailed security status of netty please refer to its security tracker page at: https://security-tracker.debian.org/tracker/netty

Original Source

Url : http://www.debian.org/security/2020/dsa-4597

CWE : Common Weakness Enumeration

%idName
100 %CWE-444Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

CPE : Common Platform Enumeration

TypeDescriptionCount
Application185

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2020-01-03 17:19:06
  • First insertion