Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Titlephp-imagick security update
Informations
NameDSA-4576First vendor Publication2019-11-25
VendorDebianLast vendor Modification2019-11-25
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

An out-of-bounds write vulnerability was discovered in php-imagick, a PHP extension to create and modify images using the ImageMagick API, which could result in denial of service, or potentially the execution of arbitrary code.

For the oldstable distribution (stretch), this problem has been fixed in version 3.4.3~rc2-2+deb9u1.

We recommend that you upgrade your php-imagick packages.

For the detailed security status of php-imagick please refer to its security tracker page at: https://security-tracker.debian.org/tracker/php-imagick

Original Source

Url : http://www.debian.org/security/2019/dsa-4576

CWE : Common Weakness Enumeration

%idName
100 %CWE-787Out-of-bounds Write (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application17

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-11-25 17:18:44
  • First insertion