Executive Summary

Summary
Titlemosquitto security update
Informations
NameDSA-4570First vendor Publication2019-11-17
VendorDebianLast vendor Modification2019-11-17
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:S/C:N/I:N/A:P)
Cvss Base Score4Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score8AuthenticationRequires single instance
Calculate full CVSS 2.0 Vectors scores

Detail

A vulnerability was discovered in mosquitto, a MQTT version 3.1/3.1.1 compatible message broker, allowing a malicious MQTT client to cause a denial of service (stack overflow and daemon crash), by sending a specially crafted SUBSCRIBE packet containing a topic with a extremely deep hierarchy.

For the stable distribution (buster), this problem has been fixed in version 1.5.7-1+deb10u1.

We recommend that you upgrade your mosquitto packages.

For the detailed security status of mosquitto please refer to its security tracker page at: https://security-tracker.debian.org/tracker/mosquitto

Original Source

Url : http://www.debian.org/security/2019/dsa-4570

CWE : Common Weakness Enumeration

%idName
100 %CWE-754Improper Check for Unusual or Exceptional Conditions

CPE : Common Platform Enumeration

TypeDescriptionCount
Application15

Snort® IPS/IDS

DateDescription
2019-11-26Eclipse Mosquitto MQTT SUBSCRIBE request topic parsing buffer overflow attempt
RuleID : 52006 - Revision : 1 - Type : SERVER-OTHER

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-11-17 17:18:44
  • First insertion