Executive Summary

Summary
Titlewebkit2gtk security update
Informations
NameDSA-4558First vendor Publication2019-11-04
VendorDebianLast vendor Modification2019-11-04
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector :
Cvss Base ScoreN/AAttack RangeN/A
Cvss Impact ScoreN/AAttack ComplexityN/A
Cvss Expoit ScoreN/AAuthenticationN/A
Calculate full CVSS 2.0 Vectors scores

Detail

Several vulnerabilities have been discovered in the webkit2gtk web engine:

CVE-2019-8625

Sergei Glazunov discovered that maliciously crafted web content may lead to universal cross site scripting.

CVE-2019-8720

Wen Xu discovered that maliciously crafted web content may lead to arbitrary code execution.

CVE-2019-8769

Pierre Reimertz discovered that visiting a maliciously crafted website may reveal browsing history.

CVE-2019-8771

Eliya Stein discovered that maliciously crafted web content may violate iframe sandboxing policy.

For the stable distribution (buster), these problems have been fixed in version 2.26.1-3~deb10u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to its security tracker page at: https://security-tracker.debian.org/tracker/webkit2gtk

Original Source

Url : http://www.debian.org/security/2019/dsa-4558

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-11-05 00:18:29
  • First insertion