Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Titlesquid security update
Informations
NameDSA-4507First vendor Publication2019-08-24
VendorDebianLast vendor Modification2019-08-24
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Several vulnerabilities were discovered in Squid, a fully featured web proxy cache. The flaws in the HTTP Digest Authentication processing, the HTTP Basic Authentication processing and in the cachemgr.cgi allowed remote attackers to perform denial of service and cross-site scripting attacks, and potentially the execution of arbitrary code.

For the stable distribution (buster), these problems have been fixed in version 4.6-1+deb10u1.

We recommend that you upgrade your squid packages.

For the detailed security status of squid please refer to its security tracker page at: https://security-tracker.debian.org/tracker/squid

Original Source

Url : http://www.debian.org/security/2019/dsa-4507

CWE : Common Weakness Enumeration

%idName
60 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
20 %CWE-200Information Exposure
20 %CWE-79Failure to Preserve Web Page Structure ('Cross-site Scripting') (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application299
Os2
Os1

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-08-24 17:18:41
  • First insertion