Executive Summary

Summary
Titlevlc security update
Informations
NameDSA-4504First vendor Publication2019-08-20
VendorDebianLast vendor Modification2019-08-20
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Multiple security issues were discovered in the VLC media player, which could result in the execution of arbitrary code or denial of service if a malformed file/stream is processed.

For the oldstable distribution (stretch), these problems have been fixed in version 3.0.8-0+deb9u1.

For the stable distribution (buster), these problems have been fixed in version 3.0.8-0+deb10u1.

We recommend that you upgrade your vlc packages.

For the detailed security status of vlc please refer to its security tracker page at: https://security-tracker.debian.org/tracker/vlc

Original Source

Url : http://www.debian.org/security/2019/dsa-4504

CWE : Common Weakness Enumeration

%idName
33 %CWE-416Use After Free
25 %CWE-125Out-of-bounds Read
17 %CWE-369Divide By Zero
8 %CWE-476NULL Pointer Dereference
8 %CWE-191Integer Underflow (Wrap or Wraparound)
8 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application146
Os2

Alert History

If you want to see full details history, please login or register.
0
1
DateInformations
2019-08-30 00:22:26
  • Multiple Updates
2019-08-21 00:19:30
  • First insertion