Executive Summary

Summary
Titleredis security update
Informations
NameDSA-4480First vendor Publication2019-07-11
VendorDebianLast vendor Modification2019-07-11
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:S/C:P/I:P/A:P)
Cvss Base Score6.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score8AuthenticationRequires single instance
Calculate full CVSS 2.0 Vectors scores

Detail

Multiple vulnerabilities were discovered in the HyperLogLog implementation of Redis, a persistent key-value database, which could result in denial of service or potentially the execution of arbitrary code.

For the oldstable distribution (stretch), these problems have been fixed in version 3:3.2.6-3+deb9u3.

For the stable distribution (buster), these problems have been fixed in version 5:5.0.3-4+deb10u1.

We recommend that you upgrade your redis packages.

For the detailed security status of redis please refer to its security tracker page at: https://security-tracker.debian.org/tracker/redis

Original Source

Url : http://www.debian.org/security/2019/dsa-4480

CWE : Common Weakness Enumeration

%idName
100 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application4
Application64
Os3
Os2
Os1

Alert History

If you want to see full details history, please login or register.
0
1
2
DateInformations
2019-07-18 21:23:43
  • Multiple Updates
2019-07-12 00:21:40
  • Multiple Updates
2019-07-12 00:18:16
  • First insertion