Executive Summary

Summary
Titleopenssl security update
Informations
NameDSA-4475First vendor Publication2019-07-01
VendorDebianLast vendor Modification2019-07-01
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:N)
Cvss Base Score5.8Attack RangeNetwork
Cvss Impact Score4.9Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Joran Dirk Greef discovered that overly long nonces used with ChaCha20-Poly1305 were incorrectly processed and could result in nonce reuse. This doesn't affect OpenSSL-internal uses of ChaCha20-Poly1305 such as TLS.

For the stable distribution (stretch), this problem has been fixed in version 1.1.0k-1~deb9u1. This DSA also upgrades openssl1.0 (which itself is not affected by CVE-2019-1543) to 1.0.2s-1~deb9u1

We recommend that you upgrade your openssl packages.

For the detailed security status of openssl please refer to its security tracker page at: https://security-tracker.debian.org/tracker/openssl

Original Source

Url : http://www.debian.org/security/2019/dsa-4475

CWE : Common Weakness Enumeration

%idName
100 %CWE-310Cryptographic Issues

CPE : Common Platform Enumeration

TypeDescriptionCount
Application30

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-07-02 00:18:26
  • First insertion