Executive Summary

Summary
Titlewpa security update
Informations
NameDSA-4450First vendor Publication2019-05-24
VendorDebianLast vendor Modification2019-05-24
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:N/A:P)
Cvss Base Score4.3Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

A vulnerability was found in the WPA protocol implementation found in wpa_supplication (station) and hostapd (access point).

The EAP-pwd implementation in hostapd (EAP server) and wpa_supplicant (EAP peer) doesn't properly validate fragmentation reassembly state when receiving an unexpected fragment. This could lead to a process crash due to a NULL pointer derefrence.

An attacker in radio range of a station or access point with EAP-pwd support could cause a crash of the relevant process (wpa_supplicant or hostapd), ensuring a denial of service.

For the stable distribution (stretch), this problem has been fixed in version 2:2.4-1+deb9u4.

We recommend that you upgrade your wpa packages.

For the detailed security status of wpa please refer to its security tracker page at: https://security-tracker.debian.org/tracker/wpa

Original Source

Url : http://www.debian.org/security/2019/dsa-4450

CWE : Common Weakness Enumeration

%idName
100 %CWE-476NULL Pointer Dereference

CPE : Common Platform Enumeration

TypeDescriptionCount
Application47
Application74

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-05-24 17:18:19
  • First insertion