Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Titlelibssh2 security update
Informations
NameDSA-4431First vendor Publication2019-04-13
VendorDebianLast vendor Modification2019-04-13
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score9.3Attack RangeNetwork
Cvss Impact Score10Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Chris Coulson discovered several vulnerabilities in libssh2, a SSH2 client-side library, which could result in denial of service, information leaks or the execution of arbitrary code.

For the stable distribution (stretch), these problems have been fixed in version 1.7.0-1+deb9u1.

We recommend that you upgrade your libssh2 packages.

For the detailed security status of libssh2 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libssh2

Original Source

Url : http://www.debian.org/security/2019/dsa-4431

CWE : Common Weakness Enumeration

%idName
56 %CWE-125Out-of-bounds Read
33 %CWE-190Integer Overflow or Wraparound (CWE/SANS Top 25)
11 %CWE-787Out-of-bounds Write (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application36
Application1
Os2
Os2
Os2
Os1
Os1
Os1
Os1
Os1
Os1

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-04-13 17:18:19
  • First insertion