Executive Summary

Summary
Titlepassenger security update
Informations
NameDSA-4415First vendor Publication2019-03-24
VendorDebianLast vendor Modification2019-03-24
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:H/Au:S/C:P/I:N/A:N)
Cvss Base Score2.1Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityHigh
Cvss Expoit Score3.9AuthenticationRequires single instance
Calculate full CVSS 2.0 Vectors scores

Detail

An arbitrary file read vulnerability was discovered in passenger, a web application server. A local user allowed to deploy an application to passenger, can take advantage of this flaw by creating a symlink from the REVISION file to an arbitrary file on the system and have its content displayed through passenger-status.

For the stable distribution (stretch), this problem has been fixed in version 5.0.30-1+deb9u1.

We recommend that you upgrade your passenger packages.

For the detailed security status of passenger please refer to its security tracker page at: https://security-tracker.debian.org/tracker/passenger

Original Source

Url : http://www.debian.org/security/2019/dsa-4415

CWE : Common Weakness Enumeration

%idName
100 %CWE-200Information Exposure

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1

Nessus® Vulnerability Scanner

DateDescription
2017-12-19Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_8cf25a29e06311e79b2c001e672571bc.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-03-24 13:18:26
  • First insertion