Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Titlegolang-1.7 security update
Informations
NameDSA-4379First vendor Publication2019-02-01
VendorDebianLast vendor Modification2019-02-01
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score9.3Attack RangeNetwork
Cvss Impact Score10Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

A vulnerability was discovered in the implementation of the P-521 and P-384 elliptic curves, which could result in denial of service and in some cases key recovery.

In addition this update fixes a vulnerability in "go get", which could result in the execution of arbitrary shell commands.

For the stable distribution (stretch), these problems have been fixed in version 1.7.4-2+deb9u1.

We recommend that you upgrade your golang-1.7 packages.

For the detailed security status of golang-1.7 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/golang-1.7

Original Source

Url : http://www.debian.org/security/2019/dsa-4379

CWE : Common Weakness Enumeration

%idName
50 %CWE-400Uncontrolled Resource Consumption ('Resource Exhaustion')
50 %CWE-78Improper Sanitization of Special Elements used in an OS Command ('OS Command Injection') (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1
Os3
Os1

Snort® IPS/IDS

DateDescription
2019-04-02Google Golang GET command injection attempt
RuleID : 49304 - Revision : 1 - Type : SERVER-OTHER

Nessus® Vulnerability Scanner

DateDescription
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-fe65c14082.nasl - Type : ACT_GATHER_INFO
2018-08-17Name : The remote PhotonOS host is missing multiple security updates.
File : PhotonOS_PHSA-2018-1_0-0123.nasl - Type : ACT_GATHER_INFO
2018-07-24Name : The remote PhotonOS host is missing multiple security updates.
File : PhotonOS_PHSA-2018-2_0-0034.nasl - Type : ACT_GATHER_INFO
2018-04-16Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201804-12.nasl - Type : ACT_GATHER_INFO
2018-03-27Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2018-975.nasl - Type : ACT_GATHER_INFO
2018-02-26Name : The remote Debian host is missing a security update.
File : debian_DLA-1294.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-02-01 17:18:11
  • First insertion