Executive Summary

Summary
Titleruby-json-jwt security update
Informations
NameDSA-4283First vendor Publication2018-08-31
VendorDebianLast vendor Modification2018-08-31
Severity (Vendor) N/ARevision1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:P/A:N)
Cvss Base Score5Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

It was discovered that ruby-json-jwt, a Ruby implementation of JSON web tokens performed insufficient validation of GCM auth tags.

For the stable distribution (stretch), this problem has been fixed in version 1.6.2-1+deb9u1.

We recommend that you upgrade your ruby-json-jwt packages.

For the detailed security status of ruby-json-jwt please refer to its security tracker page at: https://security-tracker.debian.org/tracker/ruby-json-jwt

Original Source

Url : http://www.debian.org/security/2018/dsa-4283

CWE : Common Weakness Enumeration

%idName
100 %CWE-347Improper Verification of Cryptographic Signature

Nessus® Vulnerability Scanner

DateDescription
2018-09-04Name : The remote Debian host is missing a security-related update.
File : debian_DSA-4283.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2018-09-01 00:18:25
  • First insertion