Executive Summary

Informations
NameCVE-2019-11365First vendor Publication2019-04-20
VendorCveLast vendor Modification2019-05-12

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

An issue was discovered in atftpd in atftp 0.7.1. A remote attacker may send a crafted packet triggering a stack-based buffer overflow due to an insecurely implemented strncpy call. The vulnerability is triggered by sending an error packet of 3 bytes or fewer. There are multiple instances of this vulnerable strncpy pattern within the code base, specifically within tftpd_file.c, tftp_file.c, tftpd_mtftp.c, and tftp_mtftp.c.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11365

CWE : Common Weakness Enumeration

%idName
100 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1

Sources (Detail)

SourceUrl
BUGTRAQ https://seclists.org/bugtraq/2019/May/16
DEBIAN https://www.debian.org/security/2019/dsa-4438
MISC https://pulsesecurity.co.nz/advisories/atftpd-multiple-vulnerabilities
https://sourceforge.net/p/atftp/code/ci/abed7d245d8e8bdfeab24f9f7f55a52c3140f...
MLIST https://lists.debian.org/debian-lts-announce/2019/05/msg00012.html

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
DateInformations
2019-05-13 05:19:21
  • Multiple Updates
2019-05-08 17:19:02
  • Multiple Updates
2019-05-08 09:19:14
  • Multiple Updates
2019-04-23 05:18:32
  • Multiple Updates
2019-04-20 17:19:25
  • First insertion