Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Informations
NameCVE-2012-1151First vendor Publication2012-09-09
VendorCveLast vendor Modification2017-08-28

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:N/A:P)
Cvss Base Score5Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Multiple format string vulnerabilities in dbdimp.c in DBD::Pg (aka DBD-Pg or libdbd-pg-perl) module before 2.19.0 for Perl allow remote PostgreSQL database servers to cause a denial of service (process crash) via format string specifiers in (1) a crafted database warning to the pg_warn function or (2) a crafted DBD statement to the dbd_st_prepare function.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1151

CWE : Common Weakness Enumeration

%idName
100 %CWE-134Uncontrolled Format String (CWE/SANS Top 25)

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:21318
 
Oval ID: oval:org.mitre.oval:def:21318
Title: RHSA-2012:1116: perl-DBD-Pg security update (Moderate)
Description: Multiple format string vulnerabilities in dbdimp.c in DBD::Pg (aka DBD-Pg or libdbd-pg-perl) module before 2.19.0 for Perl allow remote PostgreSQL database servers to cause a denial of service (process crash) via format string specifiers in (1) a crafted database warning to the pg_warn function or (2) a crafted DBD statement to the dbd_st_prepare function.
Family: unix Class: patch
Reference(s): RHSA-2012:1116-01
CESA-2012:1116
CVE-2012-1151
Version: 4
Platform(s): Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 5
CentOS Linux 5
CentOS Linux 6
Product(s): perl-DBD-Pg
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:15390
 
Oval ID: oval:org.mitre.oval:def:15390
Title: DSA-2431-1 libdbd-pg-perl -- format string vulnerabilities
Description: Niko Tyni discovered two format string vulnerabilities in DBD::Pg, a Perl DBI driver for the PostgreSQL database server, which can be exploited by a rogue database server.
Family: unix Class: patch
Reference(s): DSA-2431-1
CVE-2012-1151
Version: 5
Platform(s): Debian GNU/Linux 6.0
Debian GNU/kFreeBSD 6.0
Product(s): libdbd-pg-perl
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23752
 
Oval ID: oval:org.mitre.oval:def:23752
Title: ELSA-2012:1116: perl-DBD-Pg security update (Moderate)
Description: Multiple format string vulnerabilities in dbdimp.c in DBD::Pg (aka DBD-Pg or libdbd-pg-perl) module before 2.19.0 for Perl allow remote PostgreSQL database servers to cause a denial of service (process crash) via format string specifiers in (1) a crafted database warning to the pg_warn function or (2) a crafted DBD statement to the dbd_st_prepare function.
Family: unix Class: patch
Reference(s): ELSA-2012:1116-01
CVE-2012-1151
Version: 6
Platform(s): Oracle Linux 6
Oracle Linux 5
Product(s): perl-DBD-Pg
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23007
 
Oval ID: oval:org.mitre.oval:def:23007
Title: DEPRECATED: ELSA-2012:1116: perl-DBD-Pg security update (Moderate)
Description: Multiple format string vulnerabilities in dbdimp.c in DBD::Pg (aka DBD-Pg or libdbd-pg-perl) module before 2.19.0 for Perl allow remote PostgreSQL database servers to cause a denial of service (process crash) via format string specifiers in (1) a crafted database warning to the pg_warn function or (2) a crafted DBD statement to the dbd_st_prepare function.
Family: unix Class: patch
Reference(s): ELSA-2012:1116-01
CVE-2012-1151
Version: 7
Platform(s): Oracle Linux 6
Oracle Linux 5
Product(s): perl-DBD-Pg
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:27876
 
Oval ID: oval:org.mitre.oval:def:27876
Title: DEPRECATED: ELSA-2012-1116 -- perl-DBD-Pg security update (moderate)
Description: [2.15.1-4] - Resolves: rhbz#841131 (CVE-2012-1151)
Family: unix Class: patch
Reference(s): ELSA-2012-1116
CVE-2012-1151
Version: 4
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): perl-DBD-Pg
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application124

OpenVAS Exploits

DateDescription
2012-08-30Name : Fedora Update for perl-DBD-Pg FEDORA-2012-10892
File : nvt/gb_fedora_2012_10892_perl-DBD-Pg_fc17.nasl
2012-08-03Name : Fedora Update for perl-DBD-Pg FEDORA-2012-10871
File : nvt/gb_fedora_2012_10871_perl-DBD-Pg_fc16.nasl
2012-07-30Name : Mandriva Update for perl-DBD-Pg MDVSA-2012:112 (perl-DBD-Pg)
File : nvt/gb_mandriva_MDVSA_2012_112.nasl
2012-07-30Name : CentOS Update for perl-DBD-Pg CESA-2012:1116 centos5
File : nvt/gb_CESA-2012_1116_perl-DBD-Pg_centos5.nasl
2012-07-30Name : CentOS Update for perl-DBD-Pg CESA-2012:1116 centos6
File : nvt/gb_CESA-2012_1116_perl-DBD-Pg_centos6.nasl
2012-07-26Name : RedHat Update for perl-DBD-Pg RHSA-2012:1116-01
File : nvt/gb_RHSA-2012_1116-01_perl-DBD-Pg.nasl
2012-04-30Name : Gentoo Security Advisory GLSA 201204-08 (DBD-Pg)
File : nvt/glsa_201204_08.nasl
2012-04-30Name : Debian Security Advisory DSA 2431-1 (libdbd-pg-perl)
File : nvt/deb_2431_1.nasl

Nessus® Vulnerability Scanner

DateDescription
2014-06-13Name : The remote openSUSE host is missing a security update.
File : openSUSE-2012-180.nasl - Type : ACT_GATHER_INFO
2013-09-04Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2012-112.nasl - Type : ACT_GATHER_INFO
2013-07-12Name : The remote Oracle Linux host is missing a security update.
File : oraclelinux_ELSA-2012-1116.nasl - Type : ACT_GATHER_INFO
2012-09-06Name : The remote Mandriva Linux host is missing a security update.
File : mandriva_MDVSA-2012-112.nasl - Type : ACT_GATHER_INFO
2012-08-02Name : The remote Fedora host is missing a security update.
File : fedora_2012-10871.nasl - Type : ACT_GATHER_INFO
2012-08-02Name : The remote Fedora host is missing a security update.
File : fedora_2012-10892.nasl - Type : ACT_GATHER_INFO
2012-08-01Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20120725_perl_DBD_Pg_on_SL5_x.nasl - Type : ACT_GATHER_INFO
2012-07-26Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2012-1116.nasl - Type : ACT_GATHER_INFO
2012-07-26Name : The remote CentOS host is missing a security update.
File : centos_RHSA-2012-1116.nasl - Type : ACT_GATHER_INFO
2012-06-21Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201204-08.nasl - Type : ACT_GATHER_INFO
2012-03-12Name : The remote Debian host is missing a security-related update.
File : debian_DSA-2431.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

SourceUrl
CONFIRM http://cpansearch.perl.org/src/TURNSTEP/DBD-Pg-2.19.1/Changes
https://rt.cpan.org/Public/Bug/Display.html?id=75642
DEBIAN http://www.debian.org/security/2012/dsa-2431
GENTOO http://security.gentoo.org/glsa/glsa-201204-08.xml
MANDRIVA http://www.mandriva.com/security/advisories?name=MDVSA-2012:112
MISC http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=661536
https://bugzilla.redhat.com/show_bug.cgi?id=801733
MLIST http://www.openwall.com/lists/oss-security/2012/03/09/6
http://www.openwall.com/lists/oss-security/2012/03/10/4
REDHAT http://rhn.redhat.com/errata/RHSA-2012-1116.html
XF https://exchange.xforce.ibmcloud.com/vulnerabilities/73854
https://exchange.xforce.ibmcloud.com/vulnerabilities/73855

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
DateInformations
2017-08-29 09:23:44
  • Multiple Updates
2016-08-05 12:03:40
  • Multiple Updates
2016-04-26 21:36:50
  • Multiple Updates
2014-06-14 13:32:32
  • Multiple Updates
2014-02-17 11:08:47
  • Multiple Updates
2013-05-10 22:34:57
  • Multiple Updates
2013-04-05 13:18:42
  • Multiple Updates
2012-12-29 13:20:26
  • Multiple Updates