Executive Summary

Informations
NameCVE-2010-3658First vendor Publication2010-10-06
VendorCveLast vendor Modification2011-07-18

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score9.3Attack RangeNetwork
Cvss Impact Score10Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Adobe Reader and Acrobat 9.x before 9.4, and 8.x before 8.2.5 on Windows and Mac OS X, allow attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2010-2890, CVE-2010-3619, CVE-2010-3621, CVE-2010-3622, CVE-2010-3628, and CVE-2010-3632.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3658

CWE : Common Weakness Enumeration

idName
CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:7225
 
Oval ID: oval:org.mitre.oval:def:7225
Title: Adobe Reader and Acrobat Memory Corruption Code Execution Vulnerability.
Description: Adobe Reader and Acrobat 9.x before 9.4, and 8.x before 8.2.5 on Windows and Mac OS X, allow attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2010-2890, CVE-2010-3619, CVE-2010-3621, CVE-2010-3622, CVE-2010-3628, and CVE-2010-3632.
Family: windows Class: vulnerability
Reference(s): CVE-2010-3658
Version: 19
Platform(s): Microsoft Windows 2000
Microsoft Windows XP
Microsoft Windows Vista
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows 7
Product(s): Adobe Reader
Adobe Acrobat
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:22336
 
Oval ID: oval:org.mitre.oval:def:22336
Title: RHSA-2010:0743: acroread security update (Critical)
Description: Adobe Reader and Acrobat 9.x before 9.4, and 8.x before 8.2.5 on Windows and Mac OS X, allow attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2010-2890, CVE-2010-3619, CVE-2010-3621, CVE-2010-3622, CVE-2010-3628, and CVE-2010-3632.
Family: unix Class: patch
Reference(s): RHSA-2010:0743-01
CVE-2010-2883
CVE-2010-2884
CVE-2010-2887
CVE-2010-2889
CVE-2010-2890
CVE-2010-3619
CVE-2010-3620
CVE-2010-3621
CVE-2010-3622
CVE-2010-3625
CVE-2010-3626
CVE-2010-3627
CVE-2010-3628
CVE-2010-3629
CVE-2010-3630
CVE-2010-3632
CVE-2010-3656
CVE-2010-3657
CVE-2010-3658
Version: 250
Platform(s): Red Hat Enterprise Linux 5
Product(s): acroread
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:22988
 
Oval ID: oval:org.mitre.oval:def:22988
Title: ELSA-2010:0743: acroread security update (Critical)
Description: Adobe Reader and Acrobat 9.x before 9.4, and 8.x before 8.2.5 on Windows and Mac OS X, allow attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2010-2890, CVE-2010-3619, CVE-2010-3621, CVE-2010-3622, CVE-2010-3628, and CVE-2010-3632.
Family: unix Class: patch
Reference(s): ELSA-2010:0743-01
CVE-2010-2883
CVE-2010-2884
CVE-2010-2887
CVE-2010-2889
CVE-2010-2890
CVE-2010-3619
CVE-2010-3620
CVE-2010-3621
CVE-2010-3622
CVE-2010-3625
CVE-2010-3626
CVE-2010-3627
CVE-2010-3628
CVE-2010-3629
CVE-2010-3630
CVE-2010-3632
CVE-2010-3656
CVE-2010-3657
CVE-2010-3658
Version: 81
Platform(s): Oracle Linux 5
Product(s): acroread
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application25
Application24

OpenVAS Exploits

DateDescription
2011-03-09Name : Gentoo Security Advisory GLSA 201101-08 (acroread)
File : nvt/glsa_201101_08.nasl
2010-10-19Name : SuSE Update for acroread SUSE-SA:2010:048
File : nvt/gb_suse_2010_048.nasl
2010-10-18Name : Adobe Acrobat and Reader Multiple Vulnerabilities -Oct10 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_oct10_win.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
68435Adobe Reader / Acrobat Unspecified Memory Corruption (2010-3658)

Nessus® Vulnerability Scanner

DateDescription
2014-06-13Name : The remote openSUSE host is missing a security update.
File : suse_11_3_acroread-101007.nasl - Type : ACT_GATHER_INFO
2011-01-27Name : The remote SuSE 10 host is missing a security-related patch.
File : suse_acroread-7181.nasl - Type : ACT_GATHER_INFO
2011-01-27Name : The remote SuSE 10 host is missing a security-related patch.
File : suse_acroread_ja-7182.nasl - Type : ACT_GATHER_INFO
2011-01-24Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201101-08.nasl - Type : ACT_GATHER_INFO
2010-12-02Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_acroread-101007.nasl - Type : ACT_GATHER_INFO
2010-12-02Name : The remote SuSE 11 host is missing a security update.
File : suse_11_acroread_ja-101007.nasl - Type : ACT_GATHER_INFO
2010-10-11Name : The remote openSUSE host is missing a security update.
File : suse_11_2_acroread-101007.nasl - Type : ACT_GATHER_INFO
2010-10-11Name : The remote openSUSE host is missing a security update.
File : suse_11_1_acroread-101007.nasl - Type : ACT_GATHER_INFO
2010-10-07Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2010-0743.nasl - Type : ACT_GATHER_INFO
2010-09-09Name : The version of Adobe Acrobat on the remote Windows host is affected by multip...
File : adobe_acrobat_apsa10-02.nasl - Type : ACT_GATHER_INFO
2010-09-09Name : The version of Adobe Reader on the remote Windows host is affected by multipl...
File : adobe_reader_apsa10-02.nasl - Type : ACT_GATHER_INFO

Internal Sources (Detail)

SourceUrl
CERThttp://www.us-cert.gov/cas/techalerts/TA10-279A.html
CONFIRMhttp://www.adobe.com/support/security/bulletins/apsb10-21.html
GENTOOhttp://security.gentoo.org/glsa/glsa-201101-08.xml
REDHAThttp://www.redhat.com/support/errata/RHSA-2010-0743.html
SECUNIAhttp://secunia.com/advisories/43025
SUSEhttp://lists.opensuse.org/opensuse-security-announce/2010-10/msg00001.html
http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00006.html
VUPENhttp://www.vupen.com/english/advisories/2011/0191

Alert History

If you want to see full details history, please login or register.
0
1
2
DateInformations
2014-06-14 13:29:27
  • Multiple Updates
2014-02-17 10:57:45
  • Multiple Updates
2013-05-10 23:33:53
  • Multiple Updates