This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Summuary
CPE Namecpe:/o:google:android
Detail
VendorGoogleFirst view 2009-10-14
ProductAndroidLast view2018-07-06
VersionTypeOs
Edition 
Language 
Update 
 
CPE Productcpe:/o:google:android

Activity : Overall

Related : CVE

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
 DateAlertAccess VectorAccess ComplexityAuthentication
4.62018-07-06CVE-2018-5907LocalLowNone Requ...
4.62018-07-06CVE-2018-11304LocalLowNone Requ...
52018-06-11CVE-2017-7817NetworkLowNone Requ...
2.12018-05-10CVE-2018-6254LocalLowNone Requ...
52018-05-10CVE-2018-6246NetworkLowNone Requ...
Hide | Show 20 More...
 DateAlertAccess VectorAccess ComplexityAuthentication
6.52018-04-20CVE-2014-0900NetworkLowRequires ...
4.32017-12-27CVE-2015-7889NetworkMediumNone Requ...
4.62017-11-16CVE-2017-0865LocalLowNone Requ...
4.62017-11-16CVE-2017-0864LocalLowNone Requ...
4.62017-11-16CVE-2017-0863LocalLowNone Requ...
7.22017-11-16CVE-2017-0862LocalLowNone Requ...
7.22017-11-16CVE-2017-0843LocalLowNone Requ...
52017-10-18CVE-2014-3164NetworkLowNone Requ...
7.52017-10-03CVE-2017-0829NetworkLowNone Requ...
7.52017-10-03CVE-2017-0828NetworkLowNone Requ...
9.32017-10-03CVE-2017-0827NetworkMediumNone Requ...
9.32017-10-03CVE-2017-0826NetworkMediumNone Requ...
52017-10-03CVE-2017-0825NetworkLowNone Requ...
7.52017-10-03CVE-2017-0824NetworkLowNone Requ...
9.32017-09-27CVE-2015-1537NetworkMediumNone Requ...
7.12017-09-27CVE-2015-1526NetworkMediumNone Requ...
7.62017-09-25CVE-2016-5868NetworkHighNone Requ...
9.32017-09-21CVE-2017-9725NetworkMediumNone Requ...
9.32017-09-21CVE-2017-9724NetworkMediumNone Requ...

CWE : Common Weakness Enumeration

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
%idName
26% (229)CWE-264Permissions, Privileges, and Access Controls
24% (212)CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
13% (113)CWE-200Information Exposure
7% (64)CWE-20Improper Input Validation
4% (39)CWE-189Numeric Errors
Hide | Show 20 More...
%idName
3% (31)CWE-284Access Control (Authorization) Issues
3% (26)CWE-362Race Condition
2% (21)CWE-190Integer Overflow or Wraparound
1% (17)CWE-476NULL Pointer Dereference
1% (16)CWE-416Use After Free
1% (10)CWE-125Out-of-bounds Read
1% (9)CWE-120Buffer Copy without Checking Size of Input ('Classic Buffer Overflo...
0% (8)CWE-310Cryptographic Issues
0% (7)CWE-254Security Features
0% (7)CWE-79Failure to Preserve Web Page Structure ('Cross-site Scripting')
0% (5)CWE-787Out-of-bounds Write
0% (5)CWE-399Resource Management Errors
0% (4)CWE-19Data Handling
0% (3)CWE-352Cross-Site Request Forgery (CSRF)
0% (3)CWE-255Credentials Management
0% (3)CWE-22Improper Limitation of a Pathname to a Restricted Directory ('Path ...
0% (2)CWE-415Double Free
0% (2)CWE-326Inadequate Encryption Strength
0% (2)CWE-191Integer Underflow (Wrap or Wraparound)
0% (2)CWE-172Encoding Error

Oval Markup Language : Definitions

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
OvalIDName
oval:org.mitre.oval:def:16181Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:13945Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:22039RHSA-2011:1333: flash-plugin security update (Critical)
oval:org.mitre.oval:def:15272Cross-site scripting (XSS) vulnerability in Adobe Flash Player before 10.3.18...
oval:org.mitre.oval:def:14050Cross-site scripting (XSS) vulnerability in Adobe Flash Player before 10.3.18...
Hide | Show 20 More...
idName
oval:org.mitre.oval:def:23664ELSA-2011:1333: flash-plugin security update (Critical)
oval:org.mitre.oval:def:23393DEPRECATED: ELSA-2011:1333: flash-plugin security update (Critical)
oval:org.mitre.oval:def:16025Integer overflow in Adobe Flash Player before 10.3.183.5 on Windows, Mac OS X...
oval:org.mitre.oval:def:14132Integer overflow in Adobe Flash Player before 10.3.183.5 on Windows, Mac OS X...
oval:org.mitre.oval:def:26708Adobe Flash Player before 13.0.0.244 and 14.x and 15.x before 15.0.0.152 on W...
oval:org.mitre.oval:def:16241Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:14113Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:16156Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:14036Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:26758Adobe Flash Player before 13.0.0.244 and 14.x and 15.x before 15.0.0.152 on W...
oval:org.mitre.oval:def:21407RHSA-2012:0434: flash-plugin security update (Critical)
oval:org.mitre.oval:def:16157The NetStream class in Adobe Flash Player before 10.3.183.18 and 11.x before ...
oval:org.mitre.oval:def:15391The NetStream class in Adobe Flash Player before 10.3.183.18 and 11.x before ...
oval:org.mitre.oval:def:23671ELSA-2012:0434: flash-plugin security update (Critical)
oval:org.mitre.oval:def:23253DEPRECATED: ELSA-2012:0434: flash-plugin security update (Critical)
oval:org.mitre.oval:def:16053Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:13914Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:16141Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:14088Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solari...
oval:org.mitre.oval:def:16195DEPRECATED: Adobe Flash Player before 10.3.183.5 on Windows, Mac OS X, Linux,...

SAINT Exploits

DescriptionLink
Adobe Flash Player MP4 Sequence Parameter Set ProcessingMore info here
Adobe Reader Flash AVM2 Memory CorruptionMore info here
Adobe Flash Player Flash Content Parsing Code ExecutionMore info here
Adobe Flash Player ActionScript Function Arguments Code ExecutionMore info here
Adobe Flash Player callMethod Bytecode Memory CorruptionMore info here

Open Source Vulnerability Database (OSVDB)

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
75630Adobe Flash Player Media Streaming Logic Memory Corruption
75629Adobe Flash Player Security Control Bypass Information Disclosure
75628Adobe Flash Player Logic Error Unspecified Memory Corruption
75627Adobe Flash Player AVM Function Parameter Handling Overflow
75626Adobe Flash Player AVM2 Function Parameter Handling Overflow
Hide | Show 20 More...
idDescription
75625Adobe Flash Player Unspecified XSS
75201Adobe Flash Player SWF File Handling Arbitrary Code Execution (400 Taviso Bugs)
74800Android System Property Space ASHMEM_SET_PROT_MASK Application Sandbox Local ...
74453Android Browser HTTPS Session HTTP Set-Cookie Header HSTS includeSubDomains W...
74444Adobe Flash Player Unspecified Memory Corruption (2011-2425)
74443Adobe Flash Player Unspecified Memory Corruption (2011-2417)
74442Adobe Flash Player Unspecified Overflow (2011-2416)
74441Adobe Flash Player Unspecified Overflow (2011-2415)
74440Adobe Flash Player Unspecified Overflow (2011-2414)
74439Adobe Flash Player Unspecified Memory Corruption (2011-2140)
74438Adobe Flash Player Unspecified Cross-domain Information Disclosure
74437Adobe Flash Player BitmapData.scroll Handling Remote Overflow
74436Adobe Flash Player Unspecified Overflow (2011-2137)
74435Adobe Flash Player Unspecified Overflow (2011-2136)
74434Adobe Flash Player flash.display Memory Corruption
74433Adobe Flash Player Unspecified Overflow (2011-2134)
74432Adobe Flash Player Unspecified Overflow (2011-2130)
73467PassmanLite Password Manager for Android Cleartext Master Password Local Info...
73388Multiple Vendor libc Implentation fnmatch.c Memory Consumption DoS
73383Apache HTTP Server Portable Runtime (APR) Library apr_fnmatch() Infinite Loop...

ExploitDB Exploits

idDescription
35382Android WAPPushManager - SQL Injection
28957Android Zygote Socket Vulnerability Fork bomb Attack
19295Adobe Flash Player AVM Verification Logic Array Indexing Code Execution
18479Adobe Flash Player MP4 SequenceParameterSetNALUnit Buffer Overflow
18437Adobe Flash Player MP4 SequenceParameterSetNALUnit Remote Code Execution Exploit
Hide | Show 8 More...
idDescription
18164Android 'content://' URI Multiple Information Disclosure Vulnerabilities
17473Adobe Reader X Atom Type Confusion Vulnerability Exploit
17187Adobe Flash Player < 10.1.53 .64 Action Script Type Confusion Exploit (DEP...
17175Adobe Flash Player 10.2.153.1 SWF Memory Corruption Vulnerability
17027Adobe Flash Player AVM Bytecode Verification
16667Adobe Flash Player "Button" Remote Code Execution
15548Android 2.0/2.1 Use-After-Free Remote Code Execution on Webkit
15423Android 2.0-2.1 Reverse Shell Exploit

OpenVAS Exploits

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
2012-12-13Name : SuSE Update for flash-player openSUSE-SU-2012:0427-1 (flash-player)
File : nvt/gb_suse_2012_0427_1.nasl
2012-10-13Name : FreeBSD Ports: firefox
File : nvt/freebsd_firefox70.nasl
2012-09-10Name : Slackware Advisory SSA:2011-133-01 apr/apr-util
File : nvt/esoft_slk_ssa_2011_133_01.nasl
2012-08-30Name : FreeBSD Ports: firefox
File : nvt/freebsd_firefox69.nasl
2012-07-30Name : CentOS Update for apr CESA-2011:0507 centos4 x86_64
File : nvt/gb_CESA-2011_0507_apr_centos4_x86_64.nasl
Hide | Show 20 More...
idDescription
2012-07-30Name : CentOS Update for apr CESA-2011:0507 centos5 x86_64
File : nvt/gb_CESA-2011_0507_apr_centos5_x86_64.nasl
2012-07-30Name : CentOS Update for apr CESA-2011:0844 centos4 x86_64
File : nvt/gb_CESA-2011_0844_apr_centos4_x86_64.nasl
2012-07-30Name : CentOS Update for apr CESA-2011:0844 centos5 x86_64
File : nvt/gb_CESA-2011_0844_apr_centos5_x86_64.nasl
2012-06-05Name : RedHat Update for webkitgtk RHSA-2011:0177-01
File : nvt/gb_RHSA-2011_0177-01_webkitgtk.nasl
2012-04-30Name : FreeBSD Ports: linux-f10-flashplugin
File : nvt/freebsd_linux-f10-flashplugin2.nasl
2012-04-30Name : Gentoo Security Advisory GLSA 201204-07 (Adobe Flash Player)
File : nvt/glsa_201204_07.nasl
2012-03-30Name : Adobe Flash Player Code Execution and DoS Vulnerabilities (Linux)
File : nvt/secpod_adobe_flash_player_code_exec_n_dos_vuln_lin.nasl
2012-03-30Name : Adobe Flash Player Code Execution and DoS Vulnerabilities (MAC OS X)
File : nvt/secpod_adobe_prdts_code_exec_n_dos_vuln_macosx.nasl
2012-03-30Name : Adobe Flash Player Code Execution and DoS Vulnerabilities (Windows)
File : nvt/secpod_adobe_prdts_code_exec_n_dos_vuln_win.nasl
2012-03-07Name : Fedora Update for apr FEDORA-2012-1656
File : nvt/gb_fedora_2012_1656_apr_fc15.nasl
2012-02-12Name : Gentoo Security Advisory GLSA 201201-19 (acroread)
File : nvt/glsa_201201_19.nasl
2012-02-12Name : Gentoo Security Advisory GLSA 201110-11 (Adobe Flash Player)
File : nvt/glsa_201110_11.nasl
2011-11-15Name : CA Gateway Security Remote Code Execution Vulnerability
File : nvt/gb_ca_gateway_security_remote_code_execution_vuln.nasl
2011-10-20Name : Mac OS X v10.6.8 Multiple Vulnerabilities (2011-006)
File : nvt/gb_macosx_su11-006.nasl
2011-10-16Name : FreeBSD Ports: linux-flashplugin
File : nvt/freebsd_linux-flashplugin19.nasl
2011-09-30Name : Adobe Flash Player Multiple Vulnerabilities September-2011 (Linux)
File : nvt/secpod_adobe_flash_player_mult_vuln_lin_sep11.nasl
2011-09-30Name : Adobe Flash Player Multiple Vulnerabilities September-2011 (Mac OS X)
File : nvt/secpod_adobe_flash_player_mult_vuln_macosx_sep11.nasl
2011-09-30Name : Adobe Flash Player Multiple Vulnerabilities September-2011 (Windows)
File : nvt/secpod_adobe_flash_player_mult_vuln_win_sep11.nasl
2011-09-21Name : FreeBSD Ports: linux-flashplugin
File : nvt/freebsd_linux-flashplugin18.nasl
2011-09-07Name : Mac OS X v10.6.4 Multiple Vulnerabilities (2010-007)
File : nvt/gb_macosx_su10-007.nasl

Information Assurance Vulnerability Management (IAVM)

idDescription
2015-A-0221Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity : Category I - VMSKEY : V0061469
2015-A-0223Multiple Security Vulnerabilities in Mozilla Products
Severity : Category I - VMSKEY : V0061473
2014-A-0064Multiple Vulnerabilities in Mozilla Products
Severity : Category I - VMSKEY : V0050011
2014-A-0043Multiple Vulnerabilities in Mozilla Products
Severity : Category I - VMSKEY : V0046769
2014-B-0003Multiple Security Vulnerabilities in Google Chrome
Severity : Category I - VMSKEY : V0043401
Hide | Show 1 More...
idDescription
2012-B-0048Multiple Vulnerabilities in HP Systems Insight Manager
Severity : Category I - VMSKEY : V0032178

Snort® IPS/IDS

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
DateDescription
2019-09-24Adobe Flash Player malformed ATF heap overflow attempt
RuleID : 51226 - Type : FILE-FLASH - Revision : 1
2019-09-24Adobe Flash Player malformed ATF heap overflow attempt
RuleID : 51225 - Type : FILE-FLASH - Revision : 1
2019-09-19Adobe Flash player memory corruption attempt
RuleID : 51082 - Type : FILE-FLASH - Revision : 1
2019-09-19Adobe Flash player memory corruption attempt
RuleID : 51081 - Type : FILE-FLASH - Revision : 1
2018-03-27Adobe Flash Player ByteArray shading memory leak attempt
RuleID : 45744 - Type : FILE-FLASH - Revision : 1
Hide | Show 20 More...
DateDescription
2018-03-27Adobe Flash Player ByteArray shading memory leak attempt
RuleID : 45743 - Type : FILE-FLASH - Revision : 1
2018-03-13Adobe Flash Player movieclip duplicateMovieClip use-after-free attempt
RuleID : 45616 - Type : FILE-FLASH - Revision : 2
2018-03-13Adobe Flash Player movieclip duplicateMovieClip use-after-free attempt
RuleID : 45615 - Type : FILE-FLASH - Revision : 2
2018-03-13Adobe Flash Player Selection.SetSelection use-after-free attempt
RuleID : 45614 - Type : FILE-FLASH - Revision : 1
2018-03-13Adobe Flash Player Selection.SetSelection use-after-free attempt
RuleID : 45613 - Type : FILE-FLASH - Revision : 1
2018-02-20Adobe Flash Player movieclip startdrag use-after-free attempt
RuleID : 45501 - Type : FILE-FLASH - Revision : 1
2018-02-20Adobe Flash Player movieclip startdrag use-after-free attempt
RuleID : 45500 - Type : FILE-FLASH - Revision : 1
2018-02-20Adobe Flash Player movieclip attachbitmap use-after-free attempt
RuleID : 45459 - Type : FILE-FLASH - Revision : 2
2018-02-20Adobe Flash Player movieclip attachbitmap use-after-free attempt
RuleID : 45458 - Type : FILE-FLASH - Revision : 1
2018-02-06Adobe Flash Player null pointer dereference attempt
RuleID : 45356 - Type : FILE-FLASH - Revision : 2
2018-01-03Adobe Flash Player use after free attempt
RuleID : 45085 - Type : FILE-FLASH - Revision : 2
2017-03-07Adobe Flash Player AS2 TextField antiAliasType use after free attempt
RuleID : 41486 - Type : FILE-FLASH - Revision : 2
2017-03-07Adobe Flash Player AS2 TextField antiAliasType use after free attempt
RuleID : 41485 - Type : FILE-FLASH - Revision : 2
2017-02-25Adobe Flash Player custom toString function attempt
RuleID : 41412 - Type : FILE-FLASH - Revision : 5
2017-02-25Adobe Flash Player custom toString function attempt
RuleID : 41411 - Type : FILE-FLASH - Revision : 5
2017-01-19Adobe Flash Player TextField setter use after free attempt
RuleID : 41046 - Type : FILE-FLASH - Revision : 4
2017-01-19Adobe Flash Player TextField setter use after free attempt
RuleID : 41045 - Type : FILE-FLASH - Revision : 4
2016-12-20Adobe Flash Player TextField text use after free attempt
RuleID : 40819 - Type : FILE-FLASH - Revision : 2
2016-12-20Adobe Flash Player TextField text use after free attempt
RuleID : 40818 - Type : FILE-FLASH - Revision : 2
2016-12-20Adobe Flash Player LoadVars use-after-free attempt
RuleID : 40781 - Type : FILE-FLASH - Revision : 2

Nessus® Vulnerability Scanner

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
2018-04-27Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2018-1062.nasl - Type : ACT_GATHER_INFO
2018-02-28Name : The version of Arista Networks EOS running on the remote device is affected b...
File : arista_eos_sa0023.nasl - Type : ACT_GATHER_INFO
2017-12-14Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3659.nasl - Type : ACT_GATHER_INFO
2017-12-14Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2017-0174.nasl - Type : ACT_GATHER_INFO
2017-12-11Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3657.nasl - Type : ACT_GATHER_INFO
Hide | Show 20 More...
idDescription
2017-12-11Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3658.nasl - Type : ACT_GATHER_INFO
2017-12-11Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2017-0173.nasl - Type : ACT_GATHER_INFO
2017-11-08Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2017-0168.nasl - Type : ACT_GATHER_INFO
2017-11-03Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3636.nasl - Type : ACT_GATHER_INFO
2017-11-03Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3637.nasl - Type : ACT_GATHER_INFO
2017-11-03Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2017-2920-1.nasl - Type : ACT_GATHER_INFO
2017-10-06Name : A web browser installed on the remote macOS or Mac OS X host is affected by m...
File : macosx_firefox_56_0.nasl - Type : ACT_GATHER_INFO
2017-10-06Name : A web browser installed on the remote Windows host is affected by multiple vu...
File : mozilla_firefox_56_0.nasl - Type : ACT_GATHER_INFO
2017-09-29Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_1098a15bb0f642b7b5c78a8646e8be07.nasl - Type : ACT_GATHER_INFO
2017-09-20Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2017-2525-1.nasl - Type : ACT_GATHER_INFO
2017-09-19Name : The remote Ubuntu host is missing one or more security-related patches.
File : ubuntu_USN-3422-1.nasl - Type : ACT_GATHER_INFO
2017-09-11Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2017-2389-1.nasl - Type : ACT_GATHER_INFO
2017-08-25Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2017-1842.nasl - Type : ACT_GATHER_INFO
2017-08-25Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3609.nasl - Type : ACT_GATHER_INFO
2017-08-25Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2017-0145.nasl - Type : ACT_GATHER_INFO
2017-08-22Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20170801_kernel_on_SL7_x.nasl - Type : ACT_GATHER_INFO
2017-08-21Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3606.nasl - Type : ACT_GATHER_INFO
2017-08-21Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2017-3607.nasl - Type : ACT_GATHER_INFO
2017-08-21Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2017-0144.nasl - Type : ACT_GATHER_INFO
2017-08-18Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3945.nasl - Type : ACT_GATHER_INFO