This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Summuary
CPE Namecpe:/a:nodejs:node.js:0.9.8
Detail
VendorNodejsFirst view 2014-10-18
ProductNode.JsLast view2019-03-28
Version0.9.8TypeApplication
Edition 
Language 
Update 
 
CPE Productcpe:/a:nodejs:node.js

Activity : Overall

Related : CVE

 DateAlertAccess VectorAccess ComplexityAuthentication
52019-03-28CVE-2019-5739NetworkLowNone Requ...
1.92018-11-15CVE-2018-5407LocalMediumNone Requ...
52018-08-21CVE-2018-12115NetworkLowNone Requ...
42018-06-04CVE-2017-16024NetworkLowRequires ...
52018-05-17CVE-2018-7159NetworkLowNone Requ...
Hide | Show 13 More...
 DateAlertAccess VectorAccess ComplexityAuthentication
52017-01-23CVE-2015-8860NetworkLowNone Requ...
52017-01-23CVE-2015-8859NetworkLowNone Requ...
4.32017-01-23CVE-2015-8856NetworkMediumNone Requ...
7.82017-01-23CVE-2015-8855NetworkLowNone Requ...
4.32017-01-23CVE-2014-9772NetworkMediumNone Requ...
4.32017-01-23CVE-2013-7454NetworkMediumNone Requ...
4.32017-01-23CVE-2013-7453NetworkMediumNone Requ...
4.32017-01-23CVE-2013-7452NetworkMediumNone Requ...
4.32016-09-26CVE-2016-6306NetworkMediumNone Requ...
7.82016-09-26CVE-2016-6304NetworkLowNone Requ...
7.52016-09-16CVE-2016-6303NetworkLowNone Requ...
7.52015-07-09CVE-2015-5380NetworkLowNone Requ...
52014-10-18CVE-2014-7191NetworkLowNone Requ...

CWE : Common Weakness Enumeration

%idName
27% (5)CWE-79Failure to Preserve Web Page Structure ('Cross-site Scripting')
16% (3)CWE-399Resource Management Errors
16% (3)CWE-200Information Exposure
11% (2)CWE-787Out-of-bounds Write
5% (1)CWE-400Uncontrolled Resource Consumption ('Resource Exhaustion')
Hide | Show 4 More...
%idName
5% (1)CWE-125Out-of-bounds Read
5% (1)CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
5% (1)CWE-59Improper Link Resolution Before File Access ('Link Following')
5% (1)CWE-20Improper Input Validation

Snort® IPS/IDS

DateDescription
2016-11-08OpenSSL OCSP Status Request Extension denial of service attempt
RuleID : 40360 - Type : SERVER-OTHER - Revision : 3

Nessus® Vulnerability Scanner

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
2019-01-02Name : Tenable Nessus running on the remote host is affected by multiple vulnerabili...
File : nessus_tns_2018_16.nasl - Type : ACT_GATHER_INFO
2019-01-02Name : Tenable Nessus running on the remote host is affected by multiple vulnerabili...
File : nessus_tns_2018_17.nasl - Type : ACT_GATHER_INFO
2018-12-28Name : The remote EulerOS host is missing a security update.
File : EulerOS_SA-2018-1434.nasl - Type : ACT_GATHER_INFO
2018-12-28Name : Node.js - JavaScript run-time environment is affected by multiple vulnerabili...
File : nodejs_2018_nov.nasl - Type : ACT_GATHER_INFO
2018-12-20Name : The remote Debian host is missing a security-related update.
File : debian_DSA-4355.nasl - Type : ACT_GATHER_INFO
Hide | Show 20 More...
idDescription
2018-12-10Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_2a86f45afc3c11e8a41400155d006b02.nasl - Type : ACT_GATHER_INFO
2018-12-01Name : The remote Debian host is missing a security-related update.
File : debian_DSA-4348.nasl - Type : ACT_GATHER_INFO
2018-11-23Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2018-325-01.nasl - Type : ACT_GATHER_INFO
2018-11-23Name : The remote Debian host is missing a security update.
File : debian_DLA-1586.nasl - Type : ACT_GATHER_INFO
2018-11-14Name : Node.js - JavaScript run-time environment is affected by multiple vulnerabili...
File : nodejs_2018_aug.nasl - Type : ACT_GATHER_INFO
2018-11-14Name : Node.js - JavaScript run-time environment is affected by multiple vulnerabili...
File : nodejs_2018_mar.nasl - Type : ACT_GATHER_INFO
2018-11-13Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_6f170cf2e6b711e8a9a8b499baebfeaf.nasl - Type : ACT_GATHER_INFO
2018-08-28Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_0904e81fa89d11e8afbbbc5ff4f77b71.nasl - Type : ACT_GATHER_INFO
2018-03-30Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_5a9bbb6e32d311e8a7696daaba161086.nasl - Type : ACT_GATHER_INFO
2018-02-28Name : The version of Arista Networks EOS running on the remote device is affected b...
File : arista_eos_sa0024_4_17.nasl - Type : ACT_GATHER_INFO
2017-10-20Name : A network management system installed on the remote host is affected by multi...
File : oracle_ilom_3_2_6.nasl - Type : ACT_GATHER_INFO
2017-08-23Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2017-2493.nasl - Type : ACT_GATHER_INFO
2017-07-20Name : A web application installed on the remote host is affected by multiple vulner...
File : oracle_e-business_cpu_jul_2017.nasl - Type : ACT_GATHER_INFO
2017-06-30Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2017-1658.nasl - Type : ACT_GATHER_INFO
2017-06-26Name : The Tenable SecurityCenter application on the remote host contains an OpenSSL...
File : securitycenter_openssl_1_0_1u.nasl - Type : ACT_GATHER_INFO
2017-05-02Name : An application installed on the remote host is affected by multiple vulnerabi...
File : oracle_secure_global_desktop_apr_2017_cpu.nasl - Type : ACT_GATHER_INFO
2017-05-01Name : The remote EulerOS host is missing multiple security updates.
File : EulerOS_SA-2016-1047.nasl - Type : ACT_GATHER_INFO
2017-04-21Name : An enterprise management application installed on the remote host is affected...
File : oracle_enterprise_manager_apr_2017_cpu.nasl - Type : ACT_GATHER_INFO
2017-03-02Name : The remote device is missing a vendor-supplied security patch.
File : f5_bigip_SOL90492697.nasl - Type : ACT_GATHER_INFO
2017-02-15Name : An application running on the remote host is affected by multiple vulnerabili...
File : nessus_tns_2016_16.nasl - Type : ACT_GATHER_INFO