This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Summuary
CPE Namecpe:/a:adobe:flash_player_for_linux
Detail
VendorAdobeFirst view 2008-12-17
ProductFlash Player For LinuxLast view2016-12-15
VersionTypeApplication
Edition 
Language 
Update 

Activity : Overall

COMMON PLATFORM ENUMERATION : Repartition per Version

CPE NameAffected CVE
cpe:/a:adobe:flash_player_for_linux:9.0.48.073
cpe:/a:adobe:flash_player_for_linux:9.0.151.073
cpe:/a:adobe:flash_player_for_linux:9.0.115.073
cpe:/a:adobe:flash_player_for_linux:9.0.3173
cpe:/a:adobe:flash_player_for_linux:9.0.124.073
Hide | Show 5 More...
CPE NameAffected CVE
cpe:/a:adobe:flash_player_for_linux:10.0.12.3673
cpe:/a:adobe:flash_player_for_linux:10.0.15.372
cpe:/a:adobe:flash_player_for_linux:11.2.202.62162
cpe:/a:adobe:flash_player_for_linux:11.2.202.64326
cpe:/a:adobe:flash_player_for_linux:11.2.202.64417

Related : CVE

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
 DateAlertAccess VectorAccess ComplexityAuthentication
102016-12-15CVE-2016-7892NetworkLowNone Requ...
7.52016-12-15CVE-2016-7890NetworkLowNone Requ...
102016-12-15CVE-2016-7881NetworkLowNone Requ...
102016-12-15CVE-2016-7880NetworkLowNone Requ...
102016-12-15CVE-2016-7879NetworkLowNone Requ...
Hide | Show 20 More...
 DateAlertAccess VectorAccess ComplexityAuthentication
102016-12-15CVE-2016-7878NetworkLowNone Requ...
102016-12-15CVE-2016-7877NetworkLowNone Requ...
102016-12-15CVE-2016-7876NetworkLowNone Requ...
102016-12-15CVE-2016-7875NetworkLowNone Requ...
102016-12-15CVE-2016-7874NetworkLowNone Requ...
102016-12-15CVE-2016-7873NetworkLowNone Requ...
102016-12-15CVE-2016-7872NetworkLowNone Requ...
102016-12-15CVE-2016-7871NetworkLowNone Requ...
102016-12-15CVE-2016-7870NetworkLowNone Requ...
102016-12-15CVE-2016-7869NetworkLowNone Requ...
102016-12-15CVE-2016-7868NetworkLowNone Requ...
102016-12-15CVE-2016-7867NetworkLowNone Requ...
102016-11-08CVE-2016-7865NetworkLowNone Requ...
102016-11-08CVE-2016-7864NetworkLowNone Requ...
102016-11-08CVE-2016-7863NetworkLowNone Requ...
102016-11-08CVE-2016-7862NetworkLowNone Requ...
102016-11-08CVE-2016-7861NetworkLowNone Requ...
102016-11-08CVE-2016-7860NetworkLowNone Requ...
102016-11-08CVE-2016-7859NetworkLowNone Requ...

CWE : Common Weakness Enumeration

%idName
41% (13)CWE-416Use After Free
29% (9)CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
16% (5)CWE-94Failure to Control Generation of Code ('Code Injection')
3% (1)CWE-254Security Features
3% (1)CWE-200Information Exposure
Hide | Show 2 More...
%idName
3% (1)CWE-190Integer Overflow or Wraparound
3% (1)CWE-20Improper Input Validation

SAINT Exploits

DescriptionLink
Adobe Flash Player ActionScript launch command executionMore info here

Open Source Vulnerability Database (OSVDB)

idDescription
67062Adobe Flash Player Unspecified Memory Corruption (2010-2213)
67061Adobe Flash Player Unspecified Memory Corruption (2010-2214)
67060Adobe Flash Player Unspecified Clickjacking (2010-2215)
67059Adobe Flash Player Multiple Unspecified Memory Corruption (2010-2216)
67057Adobe Flash Player ActionScript AVM1 ActionPush Command Arbitrary Code Execution
Hide | Show 6 More...
idDescription
52749Adobe Flash Player Settings Manager Unspecified Clickjacking
52748Adobe Flash Player Crafted SWF File Handling Arbitrary Code Execution
52747Adobe Flash Player Shockwave Flash File Processing Destroyed Object Handling ...
52746Adobe Flash Player on Linux RPATH Variable Search Path Subversion Local Privi...
52745Adobe Flash Player on Windows Mouse Pointer Display Unspecified Clickjacking
50796Adobe Flash Player on Linux SWF File Handling Arbitrary Code Execution

ExploitDB Exploits

idDescription
18761Adobe Flash Player ActionScript Launch Command Execution Vulnerability

OpenVAS Exploits

idDescription
2011-09-07Name : Mac OS X v10.6.4 Multiple Vulnerabilities (2010-007)
File : nvt/gb_macosx_su10-007.nasl
2011-03-09Name : Gentoo Security Advisory GLSA 201101-09 (adobe-flash)
File : nvt/glsa_201101_09.nasl
2010-09-10Name : SuSE Update for acroread SUSE-SA:2010:037
File : nvt/gb_suse_2010_037.nasl
2010-08-21Name : FreeBSD Ports: linux-flashplugin
File : nvt/freebsd_linux-flashplugin9.nasl
2010-08-16Name : Adobe Flash Player/Air Multiple Vulnerabilities - August10 (Linux)
File : nvt/gb_adobe_prdts_mult_dos_vuln_aug10_lin.nasl
Hide | Show 14 More...
idDescription
2010-08-16Name : Adobe Flash Player/Air Multiple Vulnerabilities - August10 (Win)
File : nvt/gb_adobe_prdts_mult_dos_vuln_aug10_win.nasl
2010-08-16Name : SuSE Update for flash-player SUSE-SA:2010:034
File : nvt/gb_suse_2010_034.nasl
2010-05-12Name : Mac OS X 10.5.7 Update / Mac OS X Security Update 2009-002
File : nvt/macosx_upd_10_5_7_secupd_2009-002.nasl
2009-11-17Name : Mac OS X Version
File : nvt/macosx_version.nasl
2009-08-17Name : SuSE Security Advisory SUSE-SA:2009:041 (flash-player)
File : nvt/suse_sa_2009_041.nasl
2009-06-05Name : Ubuntu USN-723-1 (git-core)
File : nvt/ubuntu_723_1.nasl
2009-03-13Name : Gentoo Security Advisory GLSA 200903-23 (netscape-flash)
File : nvt/glsa_200903_23.nasl
2009-03-10Name : Adobe Flash Player Multiple Vulnerabilities - Mar09 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_mar09_lin.nasl
2009-03-10Name : Adobe Flash Player Multiple Vulnerabilities - Mar09 (Win)
File : nvt/gb_adobe_flash_player_mult_vuln_mar09_win.nasl
2009-03-02Name : SuSE Security Advisory SUSE-SA:2009:011 (flash-player)
File : nvt/suse_sa_2009_011.nasl
2009-03-02Name : RedHat Security Advisory RHSA-2009:0332
File : nvt/RHSA_2009_0332.nasl
2009-03-02Name : RedHat Security Advisory RHSA-2009:0334
File : nvt/RHSA_2009_0334.nasl
2009-01-23Name : SuSE Update for flash-player SUSE-SA:2008:059
File : nvt/gb_suse_2008_059.nasl
2008-12-19Name : Adobe Flash Player for Linux SWF Processing Vulnerability
File : nvt/gb_adobe_flash_player_swf_proc_vuln.nasl

Information Assurance Vulnerability Management (IAVM)

idDescription
2009-B-0001Adobe Flash Player for Linux Remote Code Execution Vulnerability
Severity : Category II - VMSKEY : V0017978

Snort® IPS/IDS

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
DateDescription
2017-01-18Adobe Flash Player addProperty use after free attempt
RuleID : 41025 - Type : FILE-FLASH - Revision : 1
2017-01-18Adobe Flash Player addProperty use after free attempt
RuleID : 41024 - Type : FILE-FLASH - Revision : 1
2017-01-18Adobe Flash Player addProperty use after free attempt
RuleID : 41023 - Type : FILE-FLASH - Revision : 1
2017-01-18Adobe Flash Player addProperty use after free attempt
RuleID : 41022 - Type : FILE-FLASH - Revision : 1
2017-01-18Adobe Flash Player onSetFocus movie clip use after free attempt
RuleID : 41021 - Type : FILE-FLASH - Revision : 1
Hide | Show 20 More...
DateDescription
2017-01-18Adobe Flash Player onSetFocus movie clip use after free attempt
RuleID : 41020 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player writeDynamicProperties use-after-free attempt
RuleID : 41017 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player writeDynamicProperties use-after-free attempt
RuleID : 41016 - Type : FILE-FLASH - Revision : 1
2017-01-12Acrobat Flash WorkerDomain memory corruption attempt
RuleID : 41015 - Type : FILE-FLASH - Revision : 2
2017-01-12Acrobat Flash WorkerDomain memory corruption attempt
RuleID : 41014 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player NetConnection use after free attempt
RuleID : 41013 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player NetConnection use after free attempt
RuleID : 41012 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player BitmapData applyFilter integer overflow attempt
RuleID : 41011 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player BitmapData applyFilter integer overflow attempt
RuleID : 41010 - Type : FILE-FLASH - Revision : 1
2017-01-12Adobe Flash Player ActionScript vulnerable RegExp verb usage detected
RuleID : 41009 - Type : INDICATOR-COMPROMISE - Revision : 1
2017-01-12Adobe Flash Player ActionScript vulnerable RegExp verb usage detected
RuleID : 41008 - Type : INDICATOR-COMPROMISE - Revision : 1
2017-01-12Adobe Flash Player ActionScript vulnerable RegExp verb usage detected
RuleID : 41007 - Type : INDICATOR-COMPROMISE - Revision : 1
2017-01-12Adobe Flash Player ActionScript vulnerable RegExp verb usage detected
RuleID : 41006 - Type : INDICATOR-COMPROMISE - Revision : 1
2017-01-12Adobe Flash Player Primetime MediaPlayerItemLoader QOSProvider object use aft...
RuleID : 41005 - Type : FILE-FLASH - Revision : 2
2017-01-12Adobe Flash Player Primetime MediaPlayerItemLoader QOSProvider object use aft...
RuleID : 41004 - Type : FILE-FLASH - Revision : 2
2017-01-12Adobe Flash Player Primetime SDK out of bounds read attempt
RuleID : 41003 - Type : FILE-FLASH - Revision : 2
2017-01-12Adobe Flash Player Primetime SDK out of bounds read attempt
RuleID : 41002 - Type : FILE-FLASH - Revision : 2
2017-01-12Adobe Flash Player ActionScript vulnerable RegExp verb usage detected
RuleID : 41001 - Type : INDICATOR-COMPROMISE - Revision : 1
2017-01-12Adobe Flash Player ActionScript vulnerable RegExp verb usage detected
RuleID : 41000 - Type : INDICATOR-COMPROMISE - Revision : 1
2017-01-12Adobe Flash Player NetConnection proxyType invalid value out of bounds read a...
RuleID : 40999 - Type : FILE-FLASH - Revision : 2

Nessus® Vulnerability Scanner

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
2017-01-11Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201701-17.nasl - Type : ACT_GATHER_INFO
2016-12-16Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-1484.nasl - Type : ACT_GATHER_INFO
2016-12-14Name : The remote Red Hat host is missing a security update.
File : redhat-RHSA-2016-2947.nasl - Type : ACT_GATHER_INFO
2016-12-14Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-3148-1.nasl - Type : ACT_GATHER_INFO
2016-12-13Name : The remote Windows host has a browser plugin installed that is affected by mu...
File : flash_player_apsb16-39.nasl - Type : ACT_GATHER_INFO
Hide | Show 20 More...
idDescription
2016-12-13Name : The remote macOS or Mac OS X host has a browser plugin installed that is affe...
File : macosx_flash_player_apsb16-39.nasl - Type : ACT_GATHER_INFO
2016-12-13Name : The remote Windows host has a browser plugin installed that is affected by mu...
File : smb_nt_ms16-154.nasl - Type : ACT_GATHER_INFO
2016-11-23Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201611-18.nasl - Type : ACT_GATHER_INFO
2016-11-14Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-1286.nasl - Type : ACT_GATHER_INFO
2016-11-11Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_96f6bf10a73111e695ca0011d823eebd.nasl - Type : ACT_GATHER_INFO
2016-11-11Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-1285.nasl - Type : ACT_GATHER_INFO
2016-11-11Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-2778-1.nasl - Type : ACT_GATHER_INFO
2016-11-10Name : The remote Red Hat host is missing a security update.
File : redhat-RHSA-2016-2676.nasl - Type : ACT_GATHER_INFO
2016-11-08Name : The remote Windows host has a browser plugin installed that is affected by a ...
File : flash_player_apsb16-37.nasl - Type : ACT_GATHER_INFO
2016-11-08Name : The remote macOS or Mac OS X host has a browser plugin installed that is affe...
File : macosx_flash_player_apsb16-37.nasl - Type : ACT_GATHER_INFO
2016-11-08Name : The remote Windows host has a browser plugin installed that is affected by mu...
File : smb_nt_ms16-141.nasl - Type : ACT_GATHER_INFO
2016-08-29Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-1613-1.nasl - Type : ACT_GATHER_INFO
2016-06-20Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_0e3dfdde35c411e68e82002590263bf5.nasl - Type : ACT_GATHER_INFO
2016-06-20Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201606-08.nasl - Type : ACT_GATHER_INFO
2016-06-20Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-740.nasl - Type : ACT_GATHER_INFO
2016-06-20Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-743.nasl - Type : ACT_GATHER_INFO
2016-06-20Name : The remote Red Hat host is missing a security update.
File : redhat-RHSA-2016-1238.nasl - Type : ACT_GATHER_INFO
2016-06-17Name : The remote Windows host has a browser plugin installed that is affected by mu...
File : flash_player_apsb16-18.nasl - Type : ACT_GATHER_INFO
2016-06-17Name : The remote Mac OS X host has a browser plugin installed that is affected by m...
File : macosx_flash_player_apsb16-18.nasl - Type : ACT_GATHER_INFO
2016-06-17Name : The remote Windows host has a browser plugin installed that is affected by mu...
File : smb_nt_ms16-083.nasl - Type : ACT_GATHER_INFO